[FYI] Image Embedding on the forums

Ask questions about the mod here. If useful they will be added to the Q&A / Development updates.
Forum rules
Please do not post any crashes, malfunctions or other issues with the mod in this forum. If you have any issues with the mod, please post them here. This forum is only for questions/feedback towards the team, not for solving crashes.
Locked
User avatar
michaelmurfy
Posts: 209
Joined: 24 Dec 2016 22:15
Donation rank:
Location: Wellington
Contact:

21 Aug 2018 04:00

In order to keep the site secure I've opted in to using a proxy for all images that are not served securely. This ensures that the green padlock stays in place on all pages and your browser doesn't warn you about mixed content (bad!). With later versions of Google Chrome and Firefox the browser will warn users with a "Not Secure" message if any element is not served over SSL (HTTPS).

Let's demonstrate this with cats. The below image is served by a HTTP only (not secure) image host:
Image

If you navigate to the image you'll see this is proxied - the browser is still showing a green padlock however the image itself links to an image hosted on http://iforce.co.nz/ (a NZ image host).

Now, using Imgur we see a different behavior:

Image

When possible, please ensure you're using a decent image host. Imgur is recommended as it is fast and doesn't have (many) upload limits. Other viable alternatives are Flickr or Puu.sh. If you use an image host without SSL support (eg - the URL's are http instead of https) expect these to be proxied on the forums and quality to drop.

Thanks!
Promods Server Administrator



Locked
  • Information